Issue Description
Instructors may receive a message indicating that the Blackboard course is out of space when trying to upload new files to the course. This is typically only seen by those who are responsible for uploading course content. Students do not usually see this message when uploading submissions to assignments.
Environment
This can happen in any course or organization in Blackboard Learn Ultra. It is more likely to affect courses that have been in Ultra for a number of years where content is regularly copied to the next term.
Resolution
- Open the course that is out of space and navigate to the Content page.
- Click the More options button (three dots) in the upper-right corner of the Course Content panel and select Unused Files.
- Important: Verify that the List View control (top-left) is set to show only Unused Files.
- Check the selection box at the top of the list to select all the items shown.
- Click the Delete Files button in the lower-right corner of the page and click Delete on the confirmation message.
- When the message appears stating that there are no unused files for this course, close the Unused Files tool by clicking the red X in the top-left corner.
Cause
This issue occurs when large files or enough files exist in the course's Content Collection to exceed the course size limit of 3 GB. The Content Collection is the back-end storage area for all content uploaded in a course.
- Prior to July 2023, files deleted from the course were not deleted from the Content Collection and counted against the course's size limit. Unused files remaining in the Content Collection were not easy to identify.
- In July 2023, Anthology changed the default behavior when deleting files from a course to also delete those files from the Content Collection, reclaiming space to be available again.
- In January 2024, Anthology added the ability for instructors to easily identify and delete unused files in their courses.